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Steps to Resolve Certificate Not Trusted Error in the Client Device

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Issue

Users cannot access Workspot Desktop from a Windows or Mac client and are getting a certificate error. 

Certificate Not Trusted error.

Cause

Zscaler is installed on the client device, causing interference with the certificate needed for communication with Workspot Components. Despite whitelisting the following URLs in Zscaler, the issue persists. 

Note: A similar issue is observed with client devices with Digital Guardian and Netskope software.

Solution

  • Log in to Control with valid admin credentials.

  • Navigate to “Setup > Certificates.”

  • Add the Trusted Enterprise or Root Certificate of the software and map it to the user group as shown below:

Add the certificate to Control.

Note: .pem, .pkcs, .pfx, .p12, .cer, and .crt formats are supported.

  • Relaunch the Workspot Client.

  • In the Client, select “Settings > Refresh Configuration” to fetch the latest configuration.